News: No news.
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
April 21, 2014, 06:32:02
Pages: [1]
  Print  
Topic: Nokia IP120 can ping host but can't be pinged. arp -a shows spoofed mac  (Read 6923 times)
« on: March 23, 2007, 17:54:37 »
MrDetermination *
Posts: 12

SKIP TO LAST POST.  MODIFIED TITLE TO REFLECT LATEST ISSUE.

Resources acquired:
Hardware
Nokia IP110
cf2g IDE -> CF adapter - installed
PPA3312 USB to Serial - Not recognized by XP so used  this driver (folder labeled 98_2009_2K20021)
9 pin gender changer (female - female) because the USB -> Serial ends male and the console on the Nokia is male
CF to IDE adapter

Software:
PuTTY
128mb CF card
generic-pc-1.23.img and physdiskwrite 0.5.1 from  here

Project guide here

EDITED OUT FOR BREVITY.  SKIP TO LAST FEW POSTS.
« Last Edit: April 04, 2007, 00:55:46 by MrDetermination » Logged
« Reply #1 on: March 24, 2007, 23:40:39 »
cmb
Administrator
*****
Posts: 851

You need a null modem serial cable, sounds like you're using a straight serial connection.

otherwise, everything else seems OK, per my project guide you linked.
Logged
« Reply #2 on: March 26, 2007, 16:33:38 »
MrDetermination *
Posts: 12

Thanks Chris.

RadioShack had the adapter.  Now I gotta spoof some MAC addys... downloading live installer CD.
« Last Edit: March 26, 2007, 16:45:38 by MrDetermination » Logged
« Reply #3 on: March 26, 2007, 23:39:13 »
MrDetermination *
Posts: 12

EDITED TO STREAMLINE/CLEAN UP

I've done the whole thing from scratch (rewrite CF card from nothing) 3 times now, just to be sure.  I can now get a random DHCP IP assignment by connecting the Nokia to a switch and then any machine to the switch but can not ping m0n0wall.  I can not ping the host machine from the Nokia either.  The host machine does see the default gateway as 192.168.1.1

I've tried to move the port assignments around and used multiple variations of MAC addys... I must be missing something.

I've read everything I can find and done dozens of searches but there just doesn't seem to be anything out there.

I've also tried to spoofmac and leave alone OPT1.  This seems to make no difference.  In all cases whatever adapter I have as LAN is the only one that assigns IP addresses.

Code:
Copyright (c) 1992-2005 The FreeBSD Project.                                           
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994                                                                       
        The Regents of the University of California. All rights reserved.                                                                         
FreeBSD 4.11-RELEASE-p26 #0: Sat Jan 27 15:24:23 CET 2007                                                         
    root@fb411.neon1.net:/usr/src/sys/compile/M0N0WALL_GENERIC                                                             
Timecounter "i8254"  frequency 1193182 Hz                                         
CPU: NSC Geode (266.68-MHz 586-class CPU)                                         
  Origin = "Geode by NSC"  Id = 0x540  Stepping = 0  DIR=0x8147                                                               
  Features=0x808131<FPU,TSC,MSR,CX8,CMOV,MMX>                                             
real memory  = 134217728 (131072K bytes)                                       
avail memory = 113995776 (111324K bytes)                                       
Preloaded elf kernel "kernel" at 0xc1006000.                                           
Preloaded mfs_root "/mfsroot" at 0xc100609c.                                           
md0: Preloaded image </mfsroot> 11534336 bytes at 0xc0504e1c                                                           
md1: Malloc disk               
Using $PIR table, 3 entries at 0xc00f4fb0                                         
npx0: <math processor> on motherboard                                     
npx0: INT 16 interface                     
pcib0: <Host to PCI bridge> on motherboard                                         
pci0: <PCI bus> on pcib0                       
fxp0: <Intel 82559ER Embedded 10/100 Ethernet> port 0x8000-0x803f mem 0x80100000                                                                               
-0x8011ffff,0x80000000-0x80000fff irq 11 at device 14.0 on pci0                                                               
fxp0: Ethernet address 4d:4d:00:00:00:00                                       
inphy0: <i82555 10/100 media interface> on miibus0                                                 
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto                                                             
fxp1: <Intel 82559ER Embedded 10/100 Ethernet> port 0x8400-0x843f mem 0x80300000                                                                               
-0x8031ffff,0x80200000-0x80200fff irq 10 at device 15.0 on pci0                                                               
fxp1: Ethernet address 4d:4d:00:00:00:00                                       
inphy1: <i82555 10/100 media interface> on miibus1                                                 
inphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto                                                           
fxp2: <Intel 82559ER Embedded 10/100 Ethernet> port 0x8800-0x883f mem 0x80500000                                                                               
-0x8051ffff,0x80400000-0x80400fff irq 5 at device 16.0 on pci0                                                             
fxp2: Ethernet address ff:ff:ff:ff:ff:ff                                       
inphy2: <i82555 10/100 media interface> on miibus2                                                 
inphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto                                                             
isab0: <Cyrix Cx5530 PCI-ISA bridge> at device 18.0 on pci0                                                           
isa0: <ISA bus> on isab0                       
chip1: <PCI to Other bridge (vendor=1078 device=0101)> mem 0x40012000-0x400120ff                                                                               
 at device 18.1 on pci0                       
atapci0: <Cyrix 5530 ATA33 controller> port 0xfc00-0xfc0f at device 18.2 on pci0                                                                               

atapci0: Busmastering DMA not supported                                       
pci0: <unknown card> (vendor=0x1078, dev=0x0103) at 18.3                                                       
orm0: <Option ROMs> at iomem 0xe8000-0xebfff,0xec000-0xeffff on isa0                                                                   
pmtimer0 on isa0               
fdc0: ready for input in output                               
fdc0: cmd 3 failed at out byte 1 of 3                                     
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0                                             
ata1 at port 0x170-0x177,0x376 irq 15 on isa0                                             
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0                                                               
sio0 at port 0x3f8-0x3ff i                       
sio0: type 16550A, console                         
sio1 at port 0x2f8-0x2ff irq 3 on isa0                                     
sio1: type 16550A                 
BRIDGE 020214 loaded                   
IPsec: Initialized Security Association Processing.                                                   
IP Filter: v3.4.35 initialized.  Default = block all, Logging = enabled                                                                       
ad0: 122MB <TOSHIBA THNCF128MAA> [978/8/32] at ata0-master BIOSPIO                                                                 
Mounting root from ufs:/dev/md0c                               
kern.coredump: 1 -> 0                     
Found configuration on ad0.                           
Initializing timezone... done                             
Initializing PC cards... failed (probably no PC card controller present)                                                                       
Configuring firewall... done                           
Configuring LAN interface... fxp0: Microcode loaded, int_delay: 1000 usec  bundl                                                                               
e_max: 6       
done   
Configuring WAN interface... done                                 
Configuring OPT1 (OPT1) interface... done                                         
Starting syslog service... done                               
Starting webGUI... done                       
Starting DNS forwarder... done                             
Starting DHCP service... done                             
Starting NTP client... done                           


*** This is m0n0wall, version 1.23                                 
    built on Sat Mar 10 14:21:36 CET 2007 for generic-pc                                                       
    Copyright (C) 2002-2007 by Manuel Kasper. All rights reserved.                                                                 
    Visit http://m0n0.ch/wall for updates.                                         


    LAN IP address: 192.168.1.1                               

    Port configuration:                       

    LAN   -> fxp0                 
    WAN   -> fxp1                 
    OPT1  -> fxp2 (OPT1)                       


m0n0wall console setup                     
**********************                     
1) Interfaces: assign network ports                                   
2) Set up LAN IP address                       
3) Reset webGUI password                       
4) Reset to factory defaults                           
5) Reboot system               
6) Ping host           

Enter a number: 6                 

Enter a host name or IP address: 192.168.1.100                                             

PING 192.168.1.100 (192.168.1.100): 56 data bytes                                                 

--- 192.168.1.100 ping statistics ---                                     
3 packets transmitted, 0 packets received, 100% packet                                                     

Press ENTER to continue.                       



m0n0wall console setup                     
**********************
1) Interfaces: assign network ports
2) Set up LAN IP address
3) Reset webGUI password
4) Reset to factory defaults
5) Reboot system
6) Ping host

Enter a number: 5

The firewall will reboot. This may take one minute.

Do you want to proceed? (y/n) y

The firewall is rebooting now.
Waiting (max 60 seconds) for system process `vnlru' to stop...stopped
Waiting (max 60 seconds) for system process `bufdaemon' to stop...stopped
Waiting (max 60 seconds) for system process `syncer' to stop...stopped

syncing disks...
done
Uptime: 1m34s
Rebooting...

EDIT March 28th:

A gentleman on the mailing list asked me several questions.  Here was my response:

Thanks for getting back to me, [deleted for privacy].

The environment is completely controlled.  It is a separate switch from my old/running network.  Also, this is 1.23.

I tried connecting the Nokia to a random port instead of the uplink port on the switch and then XP took an IP of 192.168.10.1 with no Default Gateway assigned.

I was wrong about the IP assignment being random.  It is always at 192.168.1.199 if I leave the pool set to default.  My thinking it was random came from trying different pool ranges.  It only assigns an IP if I connect the Nokia/m0n0 port I have set to LAN with the Uplink port on the switch.
« Last Edit: March 28, 2007, 20:12:34 by MrDetermination » Logged
« Reply #4 on: March 29, 2007, 06:21:50 »
cmb
Administrator
*****
Posts: 851

From what you describe, it sounds like everything is working fine except the <spoofmac>. It's properly assigning DHCP, which doesn't require a valid MAC address, but you can't do anything that requires a valid MAC. You have to be doing something wrong with the <spoofmac> part. If you post the part of your config that contains the <spoofmac> entries maybe we'll see what you're doing wrong.
Logged
« Reply #5 on: March 29, 2007, 07:07:10 »
MrDetermination *
Posts: 12

I don't think it is me screwing up anymore.  I went back a version just now and was able to ping the host from the Nokia.  I still can't ping the Nokia but I can force the activity light to blink by dropping and renewing the connection.  I did it like 5 times with the latest version and could never ping the host from the Nokia... gotta be something to that.

... the .xml addition goes like...

Down arrow to under the ip addr tag for LAN, next line, tab tab

<spoofmac>01:11:12:13:15:16</spoofmac>  ENTER, next tag goes over ip addr tag, repeat.  Save.  Unmount.  Exit.

Or variations on that example MAC exactly verbatim as per your instructions, not using the same variation twice.

Also, I learned uplink ports can function as normal ports with Ethernet cables (which is what I was doing)... depending on your device.  To be safe I'm just using two of the middle ports on my cheapo switch from here on out.

EDIT:  Tried to roll back to v1.11 and its pretty much the same.  I can get an IP assigned but can't ping the Nokia.
« Last Edit: March 29, 2007, 07:29:28 by MrDetermination » Logged
« Reply #6 on: March 29, 2007, 07:29:10 »
cmb
Administrator
*****
Posts: 851

looks fine at a glance. not sure what else to suggest, this is one of those rare moments that shell access at the console sure would be helpful.

when you can ping another box from the Nokia console, after doing so go to the box you pinged and run 'arp -a' from a command prompt (whether Windows, BSD, Linux, OSX, they all should be the same). You should see your spoofed MAC in the ARP cache associated with the LAN IP.
Logged
« Reply #7 on: March 29, 2007, 07:34:38 »
MrDetermination *
Posts: 12

Affirmative Capn, she sees the spoofed MAC.  Still back on v1.11...
Code:
C:\Documents and Settings\Chip>ipconfig /release

C:\Documents and Settings\Chip>ipconfig /renew

Windows IP Configuration

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : local
        IP Address. . . . . . . . . . . . : 192.168.1.199
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1

C:\Documents and Settings\Chip>ping 192.168.1.1

Pinging 192.168.1.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\Chip>arp -a

Interface: 192.168.1.199 --- 0x60002
  Internet Address      Physical Address      Type
  192.168.1.1           01-22-33-44-55-06     dynamic



But what does that tell us?  Curious, really.  We know it can see the MAC over there because it gets the 192.168.1.199/24 and gateway from it already, right?

And more importantly, to me... why the heck can't I ping something we know is there?!

*head asplodes*
« Last Edit: March 29, 2007, 07:39:15 by MrDetermination » Logged
« Reply #8 on: March 31, 2007, 20:36:35 »
cmb
Administrator
*****
Posts: 851

* cmb scratches head.

no clue what's going on there. I've never had any issues like this getting the IP1xx boxes working.
Logged
« Reply #9 on: April 02, 2007, 21:02:25 »
MrDetermination *
Posts: 12

I came back up to the current version again, from scratch and moved to a different switch but get the same result.

Any alternate resources or next steps you can recommend?  Seems like a silly question... considering you wrote the thing everyone else links to on this subject Smiley
« Last Edit: April 02, 2007, 21:05:49 by MrDetermination » Logged
« Reply #10 on: April 04, 2007, 03:14:34 »
MrDetermination *
Posts: 12

Anything else I can do?

I've tried:
-only using fxp1 and fxp2, not even assigning fxp0
-putting the spoofmac line before and after ip addresses, and right after the "if" line
-spoofing Opt1 and leaving opt1 alone, both ways, with opt 1 assigned to fxp0 and fxp2 both
-multiple switches
-multiple LAN cables
-multiple host machines and operating systems
-every version from 1.11 to 1.23

I can always get arp -a to show the spoofed LAN mac now.  I can get the console to ping the host from a serial connection with no problem at all.

What else can I try with m0n0wall?  What else can I try to run on this box?  pfsense won't boot... known issue with the BSD rev.
Logged
« Reply #11 on: April 04, 2007, 04:05:04 »
cmb
Administrator
*****
Posts: 851

I don't know of anything else you can try, sorry.
Logged
« Reply #12 on: April 05, 2007, 03:20:19 »
MrDetermination *
Posts: 12

Bleh... thanks for trying, Chris.

Now, whether to save up a couple hundred bucks for a WRAP setup and try that or sell it to make up some of the WRAP costs or just to scrap the whole thing.
Logged
« Reply #13 on: June 09, 2007, 18:34:18 »
wlan_2004 *
Posts: 1

if your router ( your modem) is giveing 192.168.0.x
then tray to use 192.168.0.x in your m0n0wall... make your
m0n0wall WAN,Lan,Opt to be 192.168.1.x.

Logged
« Reply #14 on: June 21, 2007, 15:30:44 »
MrDetermination *
Posts: 12

I don't see anywhere that I'm giving it 192.168.0.x addys.  Its just a switch, so there is no assignment going on there.
Logged
 
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines