News: No news.
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
April 16, 2014, 15:33:11
Pages: [1]
  Print  
Topic: setup on CV860A mobo (NEO fanless ) with secundary ide CF card  (Read 3258 times)
« on: May 25, 2007, 21:26:12 »
svg *
Posts: 2

Hardware= http://www.lex.com.tw:8080/product/CV860A.htm with 128mb ram and a 256mb CF
The CF is connected as secondary master (no choice for primary possible)

When I boot 1.23, kernel boots fine, until /conf needs to get mounted. The system gives at the end:
- hard error reading fsbn status error ...
- NO errors about PIO.... I tried disabling UDMA, but NOK
- message about the CF that gets detected (which would mean it is (tried to be) mounted?)
- kernel.panic 1 -> 0
- error about config.xml that cannot be opened

I also tested with 2 different CF's, and with older images (which I knew ran fine about 1.5 years ago on the same hardware (not sure if it has more recent chipsets now).

I read a lot of posts about monOwall not being able to boot from ad2 (primary master), but looking at the code, I see at least  1.23 probes all drives for a conf file, so I tend to rule out that problem.

I'm not very familiar with BSD, but my last hunch is about the chipsets being more recent than 1.23 can handle.

I finally tried 1.3b2, which boots fine.

Finally, my question: am I right about it being a hardware/driver support problem, or might there exist another workaround?

1.3b2 boots, but this system needs to go in production soon, so I'd rather avoid using that if possible.

Thanks for your support,


Serge
Logged
« Reply #1 on: May 26, 2007, 06:03:41 »
clarknova ***
Posts: 148

This post has been answered on the mailing list, for anyone looking for closure.

db
Logged
« Reply #2 on: May 26, 2007, 09:06:33 »
svg *
Posts: 2

Yes, the solution is:

"Go to the BIOS and change the secondary master from AUTO/LBA to CHS!"


Serge
Logged
« Reply #3 on: January 26, 2008, 10:12:53 »
cb831 *
Posts: 5

Hi

I'm trying to get generic-pc-1.233.img on 16MB CF Card to boot on a LEX 860A but I get

FreeBSD/i386 BOOT
Default: 0:ad(0,a)/kernel
boot:
No /kernel


no matter how I set the JCF2 jumper on the board (sec. master/slave) og if I enforce CHS on the drive in the BIOS.

Please help

Thanks
cb
Logged
« Reply #4 on: January 26, 2008, 18:50:47 »
cb831 *
Posts: 5

I'm trying to get generic-pc-1.233.img on 16MB CF Card to boot on a LEX 860A but I get

FreeBSD/i386 BOOT
Default: 0:ad(0,a)/kernel
boot:
No /kernel


no matter how I set the JCF2 jumper on the board (sec. master/slave) og if I enforce CHS on the drive in the BIOS.

I tried another CF card which worked. Then I reformatted and reloaded the 16M card and that worked too.
Logged
 
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines