News: No news.
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
April 20, 2014, 23:38:43
Pages: [1]
  Print  
Topic: 1.8.0b512 IPv6 DHCP and Comcast  (Read 1445 times)
« on: August 15, 2012, 21:22:58 »
Fred Grayson
Global Moderator
*****
Posts: 900

Using my GB-1000 with the later type Intel NICs.

My ISP has turned up native IPv6 in my area. DHCP is used on the WAN to obtain both IPv4 and IPv6 addresses.

However, m0n0 will not obtain an IPv6 address. It will get one if I use 6to4, but this is nothing new.

I tried the latest pfsense 2.1 beta and it obtains an IPv6 address just fine via DHCP.

Anyone have any debugging suggestions?

Edit:

This is partially solved as follows:

I reset m0n0wall to default configuration, and rebooted.

Next I shut off the cable modem for about one minute and then turned it on.

Once the cable modem fully stabilized, I rebooted m0n0wall and configure m0n0wall for IPv6 via DHCP and DHCP-PD, and then rebooted m0n0wall.

I now have IPv6.

If I now restore my previous m0n0wall configuration and repeat the reboots for modem and m0n0wall as before, no IPv6. So there is something in my m0n0wall configuration that breaks IPv6.

When IPv6 is broken I see this in the System Log:

dhcp6c[210]: dhcp6_ctl_authinit: failed to open /usr/local/etc/dhcp6cctlkey: No such file or directory

And I get many of these (Blocked packets) in the Firewall Log:

11:58:38.729309   WAN   fe80::2d0:68ff:fe00:8e6b, port 546   ff02::1:2, port 547   UDP


I guess all I can do now is to start with a m0n0wall default configuration and build it up slowly to where I was and see what insertion breaks IPv6.

Edit:

I have determined that it is the Traffic Shaper. I enabled it and used the Magic Shaper wizard to create rules. Rebooting m0n0wall and IPv6 is broken. Even if I now disable the Shaper, it's still broken. The only way to get IPv6 back up again is to go back into the Magic Shaper and press the Remove button. This clears the rules from the Shaper page and a reboot has IPv6 working again.

The Shaper has been problematic for me in the past too. See:

http://forum.m0n0.ch/index.php/topic,5124.msg15830.html#msg15830

Edit:

Using IPv6 via DHCP and DHCP-PD has resulted in instability that eventually crashes the box. I see this in the System Log before it dies:

Aug 17 17:05:30   last message repeated 173 times
Aug 17 16:55:29   last message repeated 39 times
Aug 17 16:53:26   last message repeated 10 times
Aug 17 16:52:50   rtadvd[210]: <ra_input> received RA from fe80::201:5cff:fe22:c9c1 on non-advertising interface(fxp1)


When I used to have a Hurricane Electric IPv6 tunnel, it was rock solid, never crashed the box. I don't recall if the Traffic Shaper was enabled or not on that configuration.


« Last Edit: August 17, 2012, 23:13:58 by Fred Grayson » Logged

--
Google is your friend and Bob's your uncle.
 
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines