News: No news.
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
August 29, 2014, 22:21:08
Pages: [1] 2 3
  Print  
Topic: Intel D945GCLF2 (Atom) onboard NIC (Realtek 8111C), solved!  (Read 25450 times)
« on: June 01, 2009, 19:22:15 »
crotale *
Posts: 22

I jumped the gun a little to quick and realized that this onboard NIC isn't supported by m0n0wall.

I believe this is a really nice system for m0n0wall and I would like to help or try as far as I can to
get this onboard NIC supported.

I did a little research and as the topic explains the board has a Realtek 8111C NIC.
According to Realtek's homepage, they have a driver for FreeBSD 5.4 and 6.0 aswell
as Linux kernel 2.4.x and 2.6.x.

As far as I have understood, m0n0wall is based on FreeBSD 6.x.

Realtek:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

I'm by far a Linux guy, but I love m0n0wall and I would really like to get it working on this board.

What is required to get it working?

I will try to help, test and supply information as much as I can, but I don't really know where to begin.

EDIT: Changed the title and post to reflect the correct NIC, Realtek 8111C.
« Last Edit: January 12, 2010, 15:47:59 by crotale » Logged
« Reply #1 on: June 04, 2009, 19:30:06 »
Manuel Kasper
Administrator
*****
Posts: 361

Are you sure it's a 8168? I'm asking because Realtek 8168 should be supported by the if_re driver in FreeBSD 6.3 - therefore, it should be recognized by m0n0wall 1.3b16. However, if it's actually a 8111C, then you're probably SOL, as that is only supported in FreeBSD 7.1 and up (and it will take a while until m0n0wall uses that). The drivers provided by Realtek are probably too outdated to work reliably with FreeBSD 6.3.
Logged
« Reply #2 on: June 22, 2009, 15:47:18 »
crotale *
Posts: 22

Thank you Manuel,

Definitely my bad, that board uses the 8111C Realtek IC.

Do you mind clarifying what you mean with "The drivers provided by Realtek are probably too outdated to work reliably with FreeBSD 6.3."
I would have thought that the IC was too new?

I found this link to be somewhat interesting:
http://www.sebsgarage.com/2009/01/realtek-rtl8111c-freenas-0-69

It's about getting the very same IC to work with FreeNAS. He mentions that he compiled it for FreeBSD 6.4, would it be much different
to do the same steps for FreeBSD 6.3?
The driver he's using from Realtek is found here:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

I see that there is a precompiled driver included in the downloadable file and that they have an "easy" method of getting the driver loaded:
1. Copy if_rl.ko in "modules" directory to "/modules" directory and overwrite the existing file.
2. Modify the file "/boot/defaults/loader.conf" and set "if_rl_load" in "Network drivers" section to "Yes"
3. Reboot.

What is required to do this with the current beta?
Logged
« Reply #3 on: June 24, 2009, 22:39:19 »
crotale *
Posts: 22

I tried this:

- adding the if_rl.ko to /boot/kernel/
- add the line: set if_rl_load="YES" before /boot

It did not work.
I can see kernel.ko getting loaded but not the if_rl.ko


*EDIT* Moved the set if_rl_load="YES" line to just below the other set commands.
Still can't get the module to load :/
How should I do it correctly?
« Last Edit: June 24, 2009, 22:48:58 by crotale » Logged
« Reply #4 on: October 11, 2009, 23:56:01 »
GraveR *
Posts: 1

The trick is to modify loader.rc.

Just above 'boot' add
Code:
load /path/to/if_rl.ko

And you're probably done.

If not, you also should swap out the kernel with one that does NOT include if_rl and if_re (like I did). This works!

Logged
« Reply #5 on: October 12, 2009, 13:02:40 »
echappatte *
Posts: 22

Try to search on freeNAS forum :
http://sourceforge.net/apps/phpbb/freenas/index.php

Freenas 0.6x is on the same base as m0n0 13bx :  freeBSD 6.x

I have this Intel board and I have tried to add this driver to use gigabit lan, it never worked (but I dont know freeBSD). In the forum, some people have succedded with 0.69 version (dont try freeNAS 0.7x, this version is based on freebsd 7.x
Logged
« Reply #6 on: October 26, 2009, 16:04:44 »
ginggs *
Posts: 13

The trick is to modify loader.rc.

Just above 'boot' add
Code:
load /path/to/if_rl.ko

And you're probably done.
Thanks GraveR, you are a star!

I installed FreeBSD 6.4 onto the D945GCLF2 board, downloaded the Realtek driver version 1.79 from their website and followed the instructions in their readme to build the driver.
I then mounted the CF card with m0n0wall 1.3b18 installed and dropped if_rl.ko into /boot/kernel on the card.  The only other change was to modify loader.rc as suggested above.
Logged
« Reply #7 on: November 24, 2009, 12:21:34 »
monk2316 *
Posts: 2

Hi,

I built an atom system (also intel D945GCLF2) for m0n0wall... and now have the same problem with the onboard nic.

I tried the solution mentioned above but since I'm a total newby with FreeBSD I just cant get it to work... :-/

Could you please upload the .img you created? That would be very helpful!

Logged
« Reply #8 on: November 24, 2009, 12:33:48 »
ginggs *
Posts: 13

It's too big to attach, but you can download it here:
generic-pc-1.3b18-rl-1.79.img.gz (8.4MB)
MD5SUM: 94f2a101733762adfcaf93d335457177

The onboard NIC on the Intel D945GCLF2 board is actually a Realtek 8111C.
Is there any chance the updated Realtek driver can be included in the official Monowall release?

« Last Edit: November 24, 2009, 12:38:18 by ginggs » Logged
« Reply #9 on: November 24, 2009, 13:34:04 »
monk2316 *
Posts: 2

NICE!!! Thank you very much! Works like a charm...
Logged
« Reply #10 on: December 03, 2009, 17:12:56 »
ginggs *
Posts: 13

Updated for 1.3:
generic-pc-1.3-rl-1.79.img.gz (8.4MB)
MD5SUM: 3157c14a9eaba9832dd2a3028cdfb3fe

The above image also works as a firmware upgrade from 1.3b18, you must just accept that it is not signed.
« Last Edit: December 04, 2009, 10:52:28 by ginggs » Logged
« Reply #11 on: January 12, 2010, 15:42:16 »
crotale *
Posts: 22

Excellent work! Thanks for supporting the community!

I will try it as soon as I can.
Logged
« Reply #12 on: January 18, 2010, 10:55:20 »
kew *
Posts: 2

Thanks, works well with the plate D945GSEJT.

Greetings.
Logged
« Reply #13 on: March 09, 2010, 20:08:45 »
Dr.Sqaer *
Posts: 1

Hi!
Somebody can tell me about how can i add the new driver by myself ?
TNX!
Logged
« Reply #14 on: March 22, 2010, 04:00:39 »
mloebl *
Posts: 2

Hi!
Somebody can tell me about how can i add the new driver by myself ?
TNX!

I just went thru this tonight after updating to the latest version and losing my Internet access... note to self don't do that on a Sunday night  Wink  It's really easy, get a hold of if_rl.ko (I googled it as I couldn't find the compiled one on the Realtek site.)  I inserted the CF card into a PC running BSD, mounted it, copied it to the kernel directory, then as other's posted, added it to the loader.rc file.  I was in a rush to get back up, but pretty certain it's in /boot/kernel and after the load /kernel line, I added load /boot/kernel/if_rl.lo that I had just copied.  I'm not 100% on the paths, but it should be enough to get you going.

I'm not sure if this is the best way to do it, but it worked and got me going again.


-Mike
Logged
 
Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines