News: This forum is now permanently frozen.
Pages: [1]
Topic: Kernel Trap 12 when booting old Pentium board from CF card into 1.3b2  (Read 5842 times)
« on: April 02, 2007, 19:55:23 »
towolf *
Posts: 3


I wanted to report this earlier on the mailing list, but needed to test this with another CF card first; I had read something related on the mailing list.

My problem is that the beta release 1.3b2 doesn’t boot on my old machine. I see a kernel trap and a reboot afters 15 secs.

ata0: <ATA channel 0> on atapci0

Fatal trap 12: page fault while in kernel mode
fault virtual address   = 0x24
fault code              = supervisor read, page not present
instruction pointer     = 0x20:0xc0658786
stack pointer           = 0x28:0xc1820b80
frame pointer           = 0x28:0xc1820b80
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gran 1
processor flags         = interrupt enabled, resume, IOPL = 0
current process         = 0 (swapper)
trap number             = 12
panic: page fault
Uptime: 1s
Automatic reboot in 15 seconds - press a key on the console to abort

I tried with three different cards (16, 128 and 2000 MB) with the same result.
The  machine is  an old 133MHz PC with 128 MB RAM and Intel Pro NICs. I have the M0n0wall image on a CF card in a IDE2CF adapter. I don’t know what the exact specs of the board are but could check if needed.

With M0n0wall 1.24 everything works flawlessly, I just wanted to check out 1.3 for the fun of it.

Here’s a dmesg for reference:

$ dmesg
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 4.11-RELEASE-p18 #0: Mon Jun  5 11:34:12 CEST 2006
Timecounter "i8254"  frequency 1193182 Hz
CPU: Pentium/P54C (132.63-MHz 586-class CPU)
  Origin = "GenuineIntel"  Id = 0x52c  Stepping = 12
real memory  = 134217728 (131072K bytes)
avail memory = 113967104 (111296K bytes)
Preloaded elf kernel "kernel" at 0xc1006000.
Preloaded mfs_root "/mfsroot" at 0xc100609c.
Intel Pentium detected, installing workaround for F00F bug
md0: Preloaded image </mfsroot> 11534336 bytes at 0xc0504e1c
md1: Malloc disk
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
isab0: <SiS 85c503 PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <SiS 5591 ATA33 controller> port 0x400ffa0-0x400ffaf,0x2300-0x2303,0x2200-0x2207,0x2100-0x2103,0x2000-0x2007 irq 0 at device 1.1 on pci0
atapci0: Busmastering DMA not supported
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
fxp0: <Intel 82550 Pro/100 Ethernet> port 0x4040-0x407f mem 0x60020000-0x6003ffff,0x60041000-0x60041fff irq 11 at device 14.0 on pci0
fxp0: Ethernet address 00:02:b3:b4:f6:bb
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp1: <Intel 82550 Pro/100 Ethernet> port 0x4000-0x403f mem 0x60000000-0x6001ffff,0x60040000-0x60040fff irq 9 at device 15.0 on pci0
fxp1: Ethernet address 00:02:b3:b4:f5:eb
inphy1: <i82555 10/100 media interface> on miibus1
inphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pci0: <Cirrus Logic GD5436 SVGA controller> at 20.0
orm0: <Option ROM> at iomem 0xc0000-0xc7fff on isa0
pmtimer0 on isa0
ep0: <3Com 3C509-Combo EtherLink III> at port 0x300-0x30f irq 10 on isa0
ep0: Ethernet address 00:60:97:4c:35:d8
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
BRIDGE 020214 loaded
IPsec: Initialized Security Association Processing.
IP Filter: v3.4.35 initialized.  Default = block all, Logging = enabled
ad0: 7MB <LEXAR ATA FLASH> [251/2/32] at ata0-master BIOSPIO
Mounting root from ufs:/dev/md0c
fxp0: Microcode loaded, int_delay: 1000 usec  bundle_max: 6
« Reply #1 on: April 04, 2007, 01:55:49 »
cmb *****
Posts: 851

This is a FreeBSD bug of some sort. It's not something any m0n0wall developer will be able to assist much with, since none are FreeBSD committers.

What would be ideal is if you could put a hard drive in the machine, and install FreeBSD 6.2. It's possible that 6.2 fixes the issue (1.3b2 is 6.1-based), but I would guess you'll probably get the same problem with 6.2, at which point you should have info you can take to the appropriate FreeBSD list to get the problem resolved. I know that's asking a lot, but that's the only way the problem will get resolved. If you're willing to do this, post back and I can provide further guidance.

« Reply #2 on: April 04, 2007, 02:19:51 »
towolf *
Posts: 3

Hmm, too bad. The case does in fact have no movable parts (i.e. drives) and I tossed the HDD away a long time ago. The HDDs I have (>200GB) will almost certainly not work in this machine.
I 'd rather not see my trusty m0n0wall box be left behind, seeing that nice features will come into m0n0wall 1.3.
If there's something else I can put onto a card that yields more info than this I'd gladly do it.
Is there an image with FreeBSD 6.2 available check somewhere for download, a newer alpha/beta?

EDIT: Oh, the beta page says that 1.3b1 already had 6.2-RC on it:
changed base system to FreeBSD 6.2-RC1 (final 1.3 version will be based on FreeBSD 6.2-RELEASE)
« Last Edit: April 04, 2007, 02:29:35 by towolf »
« Reply #3 on: April 04, 2007, 05:06:12 »
cmb *****
Posts: 851

Ah, I didn't realize Manuel had moved up to 6.2 already. Then 6.2 definitely won't work - but will have the debugging tools required to get a backtrace and other info needed to get this fixed.

You can't do anything without a kernel with debugging support, and there isn't a m0n0wall release with debugging support.
« Reply #4 on: March 24, 2008, 14:18:07 »
towolf *
Posts: 3

Too bad:

* 1.3b9 (01/15/2008)
  * added patch for trap 12 kernel panics on Nokia IP110/IP120/IP130

This made me hopeful but it still gets the kernel trap 12.
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines