News: This forum is now permanently frozen.
Pages: [1]
Topic: Possible bug in ntp service  (Read 6663 times)
« on: August 27, 2008, 19:44:31 »
mick88 *
Posts: 10


I am not sure if this is a bug or if I get something wrong. I am using m0n0wall 1.3b14 on an Alix board.

If I enter a ntp time server in numerical format in the 'General Setup' screen, the time synchronization fails with the following error (example output from running msntp on the 'exec' screen):

/usr/local/bin/msntp -v -r -P no -l /var/run/ -x 6

msntp options: a=2 p=0 v=1 e=0.100 E=5.000 P=2147483647.000
   d=360 c=5 x=360 op=1 l=/var/run/ f=/var/db/msntp.state
msntp: bad daemon restart information
msntp: unable to locate IP address/number
msntp: Unknown error: 0

This only happens when I configure a static WAN IP address without providing a DNS server in the 'General Setup' screen.

If I provide a valid DNS server or set the WAN IP address to DHCP everything works just fine.

In my opinion this should not happen, since msntp does not need to resolve the ip address when it is provided in numerical format. Or am I missing something?

« Reply #1 on: August 27, 2008, 20:24:39 »
Manuel Kasper
Posts: 364

MSNTP's host name/address handling is a bit quirky, and had to be fixed once already (it always tried to interpret anything that started with a digit as an IP address). This is probably just another reflection of that quirkyness; however, since it can be easily worked around according to your description (by specifying a DNS server on the general setup page, which is recommended anyway), I don't think it's worth spending much time trying to fix this bug in MSNTP.

It's still good that you found out about it, though - somebody else might just run into the same problem and hopefully find this forum thread. Smiley
« Reply #2 on: February 18, 2009, 20:12:38 »
dave_it4mt *
Posts: 4

I have observed a symptom that my be caused by the same "buggy" behavour of msntp:
If I set the time server location to a IP address on the LAN then m0n0Wall starts making
DNS queries to resolve the IP address as if it were a name. The DNS queries all
get a "no such name" reply from the server but continue at about 1 per second.
I discovered this by sniffing the traffic on the WAN port. Wink

Changing the IP address to a FQDN ended the stream DNS queries but I still have not figured
out if there is a way to point msntp to an NTP server on the LAN.

« Last Edit: February 18, 2009, 20:20:42 by dave_it4mt »
« Reply #3 on: May 12, 2009, 01:51:22 »
brushedmoss ****
Posts: 446

msntp was updated to sntp in b16 , can you recheck  ?
« Last Edit: May 12, 2009, 22:50:44 by brushedmoss »
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines