News: This forum is now permanently frozen.
Pages: [1]
Topic: Problem getting IPv6 AICCU tunnel to run with PPPoE IPv4 access  (Read 2758 times)
« on: April 07, 2010, 22:05:56 »
timberwolf *
Posts: 3

Hi all,

I'm having trouble getting IPv6 up and running with m0n0wall 1.31.
I had v6 up and running like a charm while terminating PPPoE directly at my DSL router, now I switched to terminating PPPoE at my m0n0wall box and that's it, no more v6 :-(

My setup is as following:
WAN: PPPoE connection with dynamic IPv4
LAN: v4 nothing special and v6 set to SixXS provided subnet.
AICCU configuration using AYIYA(even without AYIYA no effect).

All I can see which points to an error are the following entries in the DHCP log:
Apr 7 19:51:38   sixxs-aiccu: Succesfully retrieved tunnel information for T20748
Apr 7 19:51:38   sixxs-aiccu: AICCU running as PID 13813
Apr 7 19:51:38   sixxs-aiccu: Couldn't resolve Local IPv6 (null)
Any idea what I may be doing wrong?
Seems to me that the new PPPoE interface somehow is conflicting with AICCU.

I'll gladly provide any missing information, following for starters is the output of "ifconfig -a":
$ ifconfig -a
   inet netmask 0xffffff00 broadcast
   inet6 fe80::20d:b9ff:fe15:629c%vr0 prefixlen 64 scopeid 0x1
   inet6 2a01:198:5c8:: prefixlen 64
   ether 00:0d:b9:15:62:9c
   media: Ethernet autoselect (100baseTX <full-duplex>)
   status: active
   inet6 fe80::20d:b9ff:fe15:629d%vr1 prefixlen 64 scopeid 0x2
   ether 00:0d:b9:15:62:9d
   media: Ethernet autoselect (100baseTX <full-duplex>)
   status: active
vr2: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
   ether 00:0d:b9:15:62:9e
   media: Ethernet autoselect (none)
   status: no carrier
enc0: flags=41<UP,RUNNING> mtu 1536
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
   inet netmask 0xff000000
   inet6 ::1 prefixlen 128
   inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
tun0: flags=8010<POINTOPOINT,MULTICAST> mtu 1500
   inet6 fe80::20d:b9ff:fe15:629c%ng0 prefixlen 64 scopeid 0x6
   inet --> netmask 0xffffffff

Many thanks for any help in advance!

« Reply #1 on: April 07, 2010, 22:46:45 »
brushedmoss ****
Posts: 446

make sure your clock is correct and make sure you choose the correct type (ayiya or not).

Also , when these are correct if the tunnel doesn't come up, try a reboot
« Reply #2 on: April 08, 2010, 07:17:05 »
timberwolf *
Posts: 3

The clock is set correct (usingt NTP), as before while terminating PPPoE at my DSl modem/router.
The correct type is AYIYA, also as before.
I also rebooted multiple times Sad

Any idea to the log messages?
What I noticed in the ifconfig output is that "ng0", which seems to be the PPP interface, carries the same local v6 address like "vr0", which is the LAN interface, is that to be expected?
« Reply #3 on: April 09, 2010, 09:30:22 »
timberwolf *
Posts: 3

I solved the problem unintentionally with using m0n0wall-mod.
I used the modded version to be able to assign a local IP to the wan interface when using PPPoe, cause I need access to my modem.
I then tried IPv6 with AICCU again, and now its working flawless.
I'am not sure if this problem maybe caused by a bug in AICCU or m0nowall, if I could spare some more time I would investigate this further, but that isn't likely to happen in the near-future. Sad

Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines