News: This forum is now permanently frozen.
Pages: [1]
Topic: booting from external DVD USB drive and using option 7 to install to hard disk  (Read 7913 times)
« on: September 10, 2011, 17:40:42 »
yowsers *
Posts: 49

Greetings, I recently purchased an external DVD drive Rosewill USB 2.0 Slim8x DVD Writer External Optical Drive for Mac and PC Model ROD-EX001 Black and attempted to boot into cdrom 1.33 of monowall.  I have a sata to compact flash adapter in the system (system specs are located at,5220.0.html )  The motherboard I'm using is the Intel BOXD525MW Intel Atom D525.  I was able to boot from the dvd drive with the monowall 1.33 disc in the drive.  My issue was with using the Option 7 to install monowall to the hard disk.  After I hit "y" to begin installation I would get an error message and then the screen would immediately go back to the monowall console menu.  After doing it several times I was finally able to roughly determine the error message at the bottom of the screen.  It said something about "unable to mount cdrom."  I'm guessing it has something to do with using the external USB dvd drive to install using option 7 in the menu.  My solution was to use an internal dvd drive (from sata connector on motherboard) to install and use option 7 onto the compact flash hard disk.  This worked perfectly.

I'm pretty sure the issue was with using the external USB drive to do the option 7 install.  My question is am I supposed to be able to install monowall to a hard disk from an external DVD drive (where I have booted from the cdrom 1.33 version of monowall?)  I can try and get the exact error message but it disappears from the screen so fast that I am unable to see the text on the screen and it is a real pain to try and figure it out but I'll take the time if that will help in the troubleshooting of this issue.

I noticed there was a difference in the naming scheme when I used the external dvd drive as compared to the internal.  I believe it was acd0 and cd0 (although I forget which was which, this is probably expected but figured I would mention it.)

« Reply #1 on: December 15, 2011, 02:46:11 »
yowsers *
Posts: 49

I think it is the USB dvd drive.  I tried this again on my new hardware neoware e140 and I still get the same "unable to mount cdrom."  I have a feeling it is the crappy Rosewill USB dvd drive I purchased.  I'll try and get another USB external dvd drive and see if I have better results.
« Reply #2 on: January 13, 2012, 04:58:47 »
cheezit *
Posts: 1

I have the same issue with a Pioneer DVR-xd10.  Has anyone else experienced this issue or know of any possible solution?

Also, by quickly hitting [pause] immediately after confirming "proceed" I was able to capture the error.  It is

Installing... failed! (cannot mount CD-ROM)
« Last Edit: January 13, 2012, 05:30:30 by cheezit »
« Reply #3 on: January 16, 2012, 12:21:33 »
izmir_ingilizce_kursu *
Posts: 1

thx man...
« Reply #4 on: January 19, 2012, 07:47:09 »
yowsers *
Posts: 49

thx man...

did you solve our problem? Smiley
« Reply #5 on: January 21, 2012, 18:35:40 »
yowsers *
Posts: 49

My solution was to install from USB thumb drive.  Here are the steps with modifications from the original URL (as the monowall image now seems to be compressed and needs to be gunzip whereas the article says to just run DD.)  I tried the steps from but unfortunately damn small linux did not recognize my CF flash adapter for whatever reason (I tried dsl-4.4.10.iso and dsl-4.4.10-syslinux.iso where the syslinux one is supposed to be for older hardware.)  This is why I used Ubuntu Mini Remix.

Steps taken but modified slightly from

My very high level steps:

1) USB key - boot to Ubuntu Mini Remix ( - use UNetbootin ( to write iso to USB key, once iso is written to USB key - copy generic-pc-1.33.img to the root of the USB drive
2) boot to ubuntu mini remix, choose option 3 "try unbuntu without installation"
3) once booted, use the following commands:


After you’re all booted, go ahead and switch yourself to the root user, so you don’t have to preface all your commands with “sudo”:

sudo su

After that’s been taken care of, the shell prompt should change to indicate you’re root.  After you’ve done that, let’s take a look at which drives the computer is seeing:

ls /dev | grep sd

This should print out a list of all of the drives and partitions that linux is seeing.  You should see two distinct disks, which will show up as “sda” and “sdb”.  You should also see some partitions, which will have a number at the end, like “sda1? and “sdb1?.  If you bought a new flash DOM, you’ll probably only see one partition.  This is handy, because whichever disk (e.g., “sda”) doesn’t have an associated partition (e.g., “sda1?) is more than likely your DOM.  We’ll need to know the designation for later, so keep it in mind.

To make sure that the designation you saw above is actually your DOM, we’ll narrow things down through process of elimination.  Enter this command:

mount | grep sd

And you should get a response sort of like this:

/dev/sdb1 on /cdrom type vfat...

Now we know that “sdb” is your flash drive, because that’s what is mounted at /cdrom.  This leaves “sda” as your DOM, and that’s where we’ll want to write the embedded image to.  So go ahead and navigate to the /cdrom directory, and list the directory contents:

cd /cdrom

using m0n0wall, the command is:

gunzip -c /cdrom/yyy.img | dd of=/dev/xxx bs=16k

where xxx = the drive you found using the "ls /dev | grep sd" command, ie: /dev/sda
where yyy = path to .img file for monowall, ie: /cdrom/generic-pc-1.33.img

final command would be, based on the above data:

gunzip -c /cdrom/generic-pc-1.33.img | dd of=/dev/sda bs=16k

now you are done.  you can verify the partition was written properly by using the command


and taking a look at the recently created partition.

reboot, change boot options back to HDD-0 and ready to rock

Obviously this requires that the PC you are using be able to boot from USB.  If you are using older hardware it may not have that capability so we still need a fix for the CDROM option from USB cd drive but at least this is an alternative for some.
« Last Edit: January 28, 2012, 18:00:20 by yowsers »
« Reply #6 on: February 24, 2012, 19:43:09 »
Lee Sharp *****
Posts: 517

FreeBSD has a problem with USB cd-roms on some BIOSes.  It has for a long time.  The solutions are varied.  But what I do is hook the hard drive up to my desktop via usb and use dd (physdiskwrite on windows) to write the image to the drive.
« Reply #7 on: February 25, 2012, 17:26:47 »
yowsers *
Posts: 49

I think this may be fixed in monowall v1.8 according to this changelog entry from

-installing from cdrom will try from /dev/acd0 then /dev/cd0.  Install works via remote ISO mapping on hp servers now.

Can someone who is smarter than me confirm? Smiley  I'll try and find some time before beta is over to confirm this particular use case on the same hardware I had the issue on.
« Last Edit: February 25, 2012, 17:28:31 by yowsers »
« Reply #8 on: March 25, 2012, 21:52:22 »
yowsers *
Posts: 49

tried using generic-pc-1.8.0b500.iso and still does not work.  I get the "cannot mount cd-rom" error after hitting 7 to install then choosing ad4 which is my flash disk.  when monowall gives me an option to install to (after pressing 7) I get:

cd0 - matshita dvd-ram, UJ8A0AS 1.00 22.24 MB (this is the external DVD drive Rosewill USB 2.0 Slim8x DVD Writer External Optical Drive for Mac and PC Model ROD-EX001)
ad4 - my cf disk

so something else must be happening if monowall is truly trying acd0 first and then cd0 second.

i am using the latest bios (MWPNT10N.86A.0113.BI.ZIP) on the Intel Motherboard BOXD525MW.

*note, I do notice that after the system boots, I am unable to eject the cdrom when I push the eject button.  I have to unplug the USB and plug it back in (at which point some text on the screen shows that the cd0 is disconnected and then reconnected) and then I am unable to eject the tray.  it's almost as if the cdrom goes to sleep and maybe doesn't exist as cd0 when that happens?  to test this, if I run "mount" from exec.php to see if the cd0 is still mounted should it show /dev/cd0 on the mount command?*
« Last Edit: March 25, 2012, 22:06:11 by yowsers »
« Reply #9 on: January 19, 2013, 01:43:36 »
volumetricsteve *
Posts: 10

Something is up, this has been the same problem for me too.

I finally got the image to write on a USB stick thanks to my mac, but literally nothing else has worked.

I've tried installing from a USB CD-ROM drive, and no configuration of that has worked (I get kernel panics or less)
I've also tried from a SATA CD-ROM and just like you guys, when I get to option 7, it never sees my USB drive as an option.

I seem to recall when I used m0n0wall years ago, it was a lot easier....or at least it was super-reliable, this new build seems shaky if we're all having this issue..
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines