News: This forum is now permanently frozen.
Pages: [1]
Topic: m0n0wall assumes the HDD to be connected to IDE channel 0  (Read 1763 times)
« on: November 04, 2011, 13:22:48 »
Hans Maulwurf **
Posts: 56

Technically this might not be a real bug but more of a usability issue, but it caused me some confusion:
When I switched to using a HDD instead of a USB key, I connected the HDD to a random IDE port, as they are not labeled and I was too lazy to download the manual and check which one is the primary. And technically it shouldn't matter, as you can boot just fine from an HDD connected to the secondary IDE port.

I set the HDD spin down time to 10 minutes, but the HDD kept running forever. A couple of reboots later and after playing around with ataidle on exec.php I found out that the HDD was indeed connected to the secondary IDE port.
greping through the *.inc files I found that m0n0wall just tries to set the standby timeout on channel 0 device 0.                     mwexec("/usr/local/sbin/ataidle -S $standby 0 0");

I think you should either put a note next to the spin down setting telling the user that the HDD must be connected to the first IDE port, or better yet you should just "brute force" all the IDE channels, so any HDD connected anywhere will spin down eventually.
On modern boards with 6 or 8 SATA ports this could get even more confusing...
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines