News: This forum is now permanently frozen.
Pages: [1]
Topic: [Solved] Sixxs Tunnel no longer working on Alix appliance  (Read 3257 times)
« on: March 16, 2012, 17:52:46 »
maga *
Posts: 10

Since a few weeks, my Sixxs IPv6 tunnel is no longer working. IPv4 is fine.

Sixxs has no open issues for my PoP.

M0n0wall reports the proper AICCU address (as before, when IPv6 still worked):

Mar 16 18:07:14    sixxs-aiccu: Succesfully retrieved tunnel information for T12345
Mar 16 18:07:14    sixxs-aiccu: AICCU running as PID 166
Mar 16 18:07:14    kernel: tun0: link state changed to UP
Mar 16 18:07:14    sixxs-aiccu: [AYIYA-start] : Anything in Anything (draft-02)
Mar 16 18:07:14    sixxs-aiccu: [AYIYA-tun->tundev] : (Socket to TUN) started

IPv6 address    fe80::20d:b9ff:fe23:58bd%vr1/64
IPv6 gateway    2001:1620:f00:14e::1  
AICCU address    fe80::20d:b9ff:fe23:58bc%tun0/64

The tunnel interface is up:

tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1280
   inet6 fe80::20d:b9ff:fe23:58bc%tun0 prefixlen 64 scopeid 0x6
   inet6 fe80::1420:f00:14e:2%tun0 prefixlen 64 scopeid 0x6
   inet6 2001:1620:f00:14e::2 --> 2001:1620:f00:14e::1 prefixlen 128
   Opened by PID 161

M0n0wall can ping internal IPv6 addresses, both by name and number.
External IPv6 addresses cannot be pinged, neither by name nor by number.

The routing table contains a proper entry for the default gateway:
Destination                       Gateway                       Flags      Netif Expire
default                           2001:1620:f00:14e::1          UGS        tun0

The IPv6 firewall LAN rule allowing everything out is established.

Hardware and software configuration:
PCEngines Alix2d3
M0n0wall version: generic-pc-serial-1.8.0b499.img
(same issue with older versions down to 1.33)

I found one thread at the forum with the same issue, it was solved by replacing the hardware. So I tested the same version and config on an old Pentium PC and voila - the IPv6 tunnel worked as expected.

However, I would rather use the silent fast Alix appliance than a noisy old slow PC with 10MBit network interfaces. As Alix boards are supposed to work with M0n0wall, I would really appreciate some help in debugging the issue.

Any hints on how to further debug the issue on the Alix board?
« Last Edit: March 24, 2012, 13:33:24 by maga »

Amateurs built the Ark. Professionals built the Titanic.
« Reply #1 on: March 24, 2012, 13:32:43 »
maga *
Posts: 10

IPv6 is up and running again.

It took four steps to regain the IPv6 connectivity with the Alix.2d3 board:

1. Update the firmware to 1.8.0b500
2. Remove the power for a minute
3. Set the time manually by using \exec.php, executing "date yyyymmddhhmm"
4. Reboot system using the web interface

Amateurs built the Ark. Professionals built the Titanic.
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines