News: This forum is now permanently frozen.
Pages: [1]
Topic: Default route with DHCPv6?  (Read 6162 times)
« on: June 18, 2012, 04:55:50 »
nriley *
Posts: 13


My ISP just started supporting IPv6 and I have configured m0n0wall to get an IP address via DHCPv6 and a subnet via DHCP-PD.  That all works great.

However, there's no default route so I can't send any IPv6 traffic over the WAN.  I saw in the "what works in IPv6" post that it says "default route via slaac not working".  I guess this means I must somehow configure the default route manually, but how do I do this, and how do I figure out what it should be?

« Reply #1 on: June 18, 2012, 14:29:08 »
nriley *
Posts: 13

OK, I found this thread which was quite helpful, however I don't have it working quite yet.

I disabled forwarding with sysctl, then copied in rtsol (since it didn't seem to be included) and ran it:

$ chmod +x /tmp/rtsol; /tmp/rtsol -d sis1
checking if sis1 is ready...
sis1 is ready
send RS on sis1, whose state is 2
received RA from fe80::200:24ff:fec4:78f4 on an unexpected IF(sis0)
received RA from fe80::201:5cff:fe24:b6c1 on sis1, state is 2
OtherConfigFlag on sis1 is turned on
stop timer for sis1
there is no timer

sis0 is the LAN, sis1 is the WAN and the :7874 address is m0n0wall (I'm using rtadvd, no DHCP on the LAN), so that's fine. Does that mean the :b6c1 address should be the default route?  If so, I can't figure out how to add it, and rtsol doesn't seem to add a default route itself.

I also notice that I could have got the same information from the logs, since rtadvd was complaining:

Jun 18 07:11:29 plucky rtadvd[309]: <ra_input> received RA from fe80::201:5cff:fe24:b6c1 on non-advertising interface(sis1)


« Reply #2 on: June 19, 2012, 01:42:52 »
brushedmoss ****
Posts: 446

Are you using 1.8 beta ?

1.33 doesn't work right for PD and has this problem. 1.8beta has this fixed
« Reply #3 on: June 19, 2012, 02:13:36 »
nriley *
Posts: 13

No, I'm not. So there's no workaround for 1.33?
« Reply #4 on: June 27, 2012, 21:42:06 »
brushedmoss ****
Posts: 446

The patch to get this to work in freebsd8 (m0n0wall 1.Cool doesn't back port to freebsd6 (1.33) , so i'm afraid, no and it's not a simple backport as there are some features in freebsd8 that are used to make this work correctly, they would have to be backported to.

Have you tried 1.8 ?
« Reply #5 on: June 27, 2012, 22:00:13 »
nriley *
Posts: 13

No, it'll be a few months until I can — I'm currently 1000 miles away from my box running m0n0wall and I already accidentally deleted my default route while trying to figure out a workaround.

Thanks for your work on IPv6; hopefully I'll be able to use it one of these days...
« Reply #6 on: October 21, 2012, 21:08:08 »
nriley *
Posts: 13

Just to close this up, I was able to install a 1.8 snapshot a few weeks ago and everything works great now.
« Reply #7 on: October 22, 2012, 00:56:11 »
Fred Grayson *****
Posts: 994

Just curious about your setup. If you enable the Traffic Shaper does your IPv6 via DHCPv6-DHCP-PD still work?

Google is your friend and Bob's your uncle.
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines