News: This forum is now permanently frozen.
Pages: [1]
Topic: [Solved] Upgrade from beta ver. 1.8.1-b550 to stable ver 1.8.1  (Read 1784 times)
« on: February 21, 2014, 07:20:30 »
jwhitmor *
Posts: 4

I have been testing version 1.8.1 beta (through beta 550), which is installed now. I tried to upgrade the firmware to 1.8.1 stable but the software refused to load the update. What am I doing wrong? This is the Generic-PC version.
Thank you,
« Last Edit: March 06, 2014, 00:05:13 by jwhitmor »
« Reply #1 on: February 21, 2014, 11:43:29 »
Pierre Nast *
Posts: 33


Can you give us a little more details on how you tried to do the upgrade?
What do you mean by "the software refused to load the update" ?
Can you provide a few screenshots?
If not, can you quote the message that led you to say that the software refused to load the update ?

« Reply #2 on: February 21, 2014, 18:25:02 »
jwhitmor *
Posts: 4

  Yes, from the WebGUI; I login, and select the firmware page. I then click the "enable firmware upload" button, and browse for the file: generic-pc-1.8.1.img. I select that image file, and then click the button "upgrade firmware".  At this point, I get a message at the bottom of the page that says, "sending request to (the IP address)" the page then hangs and does nothing more. If I then go to the status page I see the firmware is still the same version as before:  Version 1.8.1b550   built on Sun Nov 24 17:55:50 CET 2013; Platform Generic PC.
  I checked the MD5 hash for the file: generic-pc-1.8.1.img that I am trying to load, and the sum matches the signature on the download page, so it should be good. I have used this upgrade procedure many times with beta snapshots, and it always worked before.
I will attach an image

* WebGUI.JPG (98.19 KB, 1024x768 - viewed 167 times.)
« Last Edit: February 21, 2014, 18:33:13 by jwhitmor »
« Reply #3 on: March 02, 2014, 04:04:18 »
jwhitmor *
Posts: 4

I just tried again, with the same result. Should I wipe the flash memory card, and load as if I was building a new system?
Thank you,
« Reply #4 on: March 03, 2014, 09:08:10 »
Lee Sharp *****
Posts: 517

How are you connected to the firewall?  And how long are you waiting for it to upload?
« Reply #5 on: March 06, 2014, 00:03:45 »
jwhitmor *
Posts: 4

  I connect by plugging a cable from my laptop into the hub on the LAN side of the firewall. It has always worked in the past. I was able to log in to the GUI so I know I have connectivity. The first time I tried I waited "a few minutes", but the most recent try, I just let the laptop sit, and came back 30 minutes later and I was still on the same screen shown in my screen shot. 
  I just tried something new. I clicked on "Disable firmware upload" and then once again, clicked on " Enable firmware upload"
browsed for the file, selected it, and then clicked, "Upgrade firmware". This time it uploaded OK, rebooted, and the GUI now displays, "You are using the most recent version of m0n0wall." The System Status page now shows (correctly) version 1.8.1.
  There may have been a flag in the program in the wrong state to let me upload, and disabling and re-enabling the upload probably reset it.
   Whatever the case, all is well now.
Thank You all, for the support,
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines