News: This forum is now permanently frozen.
Pages: [1]
Topic: Console message: ad4: FAILURE - READ timed out LBA=... Kingston SSD  (Read 906 times)
« on: August 18, 2014, 13:07:40 »
whosername *
Posts: 9

I am getting these messages on the system console:
    ad4: FAILURE - READ timed out LBA=234441631
where the number after LBA= changes from time to time.

Hardware: I am using a Kingston SSDNOW 300 SATA III 120GB SSD on a Fujitsu ESPRIMO P420 E85+. The SSD connects directly to the motherboard. Chipset: Intel H81 Express.

Installation: I installed m0n0wall 1.8.1 onto the SSD by booting on the same computer from the FreeBSD 8.4 installation DVD and then from fixit copying m0n0wall from a USB memory stick to the SSD.

Troubleshooting: Some people refer to AHCI causing problems. I tried switching from AHCI to IDE in the PC BIOS (I presume as SATA II). M0n0wall then loads a different disk controller driver upon booting, but other than that the problem remains the same. I also tried to add a file /cf/boot/loader.conf containing one line (ahci_load="YES"), but I am not sure if that worked or even makes sense since it seems to me like the correct driver was being loaded. Also it seems the problem is still there even when I set the drive to IDE in the system BIOS. The problem with the SSD drive is there whether I boot m0n0wall from a USB stick (and then mounting the SSD drive from exec.php console) or when booting from the SSD drive. The drive is connected to the main SATA port on the motherboard. I tried another port and I also disconnected the DVD player, it made no difference.

To provoke the problem I can do this: dd if=/dev/ada0 of=/dev/null bs=1m. That will give me lots of timeouts reading the drive like this "ad4: TIMEOUT - READ retrying (0 retries left) LBA=..." and they eventually end with failure: "ad4: FAILURE - READ timed out LBA=..."

Any ideas?

SSD firmware 541ABBF0

I do not see any error messages for the drive in Kingston Toolbox v2.0.7A (SMART or otherwise).

gpart show ad4:
=>       0  234441648  ad4  BSD  (111G)
         0        16        - free -  (8.0k)
        16  28340     1  freebsd-ufs  (13M)
  28356    234413292        - free -  (111G)

A bit more from dmesg:
atapci0: <Intel Lynx Point SATA300 controller> port 0xf0b0-0xf0b7,0xf0a0-0xf0a3,0xf090-0xf097,0xf080-0xf083,0xf060-0xf07f mem 0xf7f1a000-0xf7f1a7ff irq 19 at device 31.2 on pci0
atapci0: [ITHREAD]
atapci0: AHCI called from vendor specific driver
atapci0: AHCI v1.30 controller with 4 6Gbps ports, PM not supported
ata2: <ATA channel> at channel 0 on atapci0
ata2: [ITHREAD]
ad4: 114473MB <KINGSTON SV300S37A120G 541ABBF0> at ata2-master PIO4 SATA 6Gb/s
ad4: FAILURE - READ timed out LBA=234441631
« Reply #1 on: August 20, 2014, 21:20:12 »
whosername *
Posts: 9

Just an update for others to see.

Kingston Support answered as follows: "It seems to be related to the OS itself and you can find many issues independent of the Drive manufacturer. The fix seems to be the Increase of hard code arbitrary timeout value. Unfortunately I will not be able to help you further as it requires changing system code from a 3rd party product."

The Kingston SSDNOW has a SandForce SF-2281 controller, I'm not sure if this works with FreeBSD 8.4 which m0n0wall 1.8.1 is running on. Does anyone know?

Instead of troubleshooting any further I have decided to boot/run M0n0wall 1.8.1 on a USB Memory stick since it runs entirely in memory. I'll go with the SanDisk Cruzer Fit 8GB.
« Reply #2 on: August 20, 2014, 23:52:31 »
Lee Sharp *****
Posts: 517

That is a better choice.  Cheaper too.
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines