News: This forum is now permanently frozen.
Pages: [1]
Topic: [Solved] on APU1C: how to copy system from SD to SSD?  (Read 3079 times)
« on: April 01, 2014, 18:18:21 »
winnall *
Posts: 10

I've got an APU1C from PC Engines and I can boot M0n0wall 1.8.1 on it from an SD. I also have an SSD installed and would like to transfer the system from the SD to the SSD and boot from the SSD.

I've discovered /exec.php, so I have the power of the shell at my disposal. But what is the SSD called? /dev/???

I guess I've got to get the M0n0wall 1.8.1 image file onto the APU1C's file system and do a dd to the SSD. Or is there another way?

Has anyone done this before? I'd be grateful for any suggestions.

« Last Edit: April 03, 2014, 17:34:54 by winnall »
« Reply #1 on: April 01, 2014, 22:24:14 »
brushedmoss ****
Posts: 446

from the boot log you should see the device name, like this

ad4: 15258MB <SuperSSpeed S238 16GB V4629> at ata2-master PIO4 SATA 3Gb/s

assuming it's ad4 , do this from exec.php
echo "ad4" > /var/etc/cfdevice

then do an upgrade to the same version or a newer snapshot, and the upgrade process will install into ad4 based on the contents of /var/etc/cfdevice

« Reply #2 on: April 01, 2014, 23:05:57 »
winnall *
Posts: 10

Thanks for this.

I've looked at the output of dmesg: there doesn't seem to be anything like that in there. I can't see any likely candidates under /dev either.

So I need to go back a step and check on the hardware, I think.

« Reply #3 on: April 01, 2014, 23:07:18 »
brushedmoss ****
Posts: 446

what is the ssd unit ?  I think you have to put it in a certain slot on the APU
« Reply #4 on: April 01, 2014, 23:27:36 »
winnall *
Posts: 10

I moved the SSD into a different position (immediately behind the serial port) and the SSD appeared as ad4.

I followed your instructions, removed the SD and the machine booted. There was much flashing of the red light on the SSD, so it seems to have worked!

Thank you very much.
« Reply #5 on: August 20, 2014, 00:37:10 »
sinloft *
Posts: 3

Thanks brushedmoss this worked for me too.
« Reply #6 on: August 23, 2014, 14:20:29 »
sike *
Posts: 2

I am having some trouble getting it on to the SSD with my APU.

The ssd is installed directly behind the Serial Port. When booting I get:

: Prad4: 14318MB <SB mSATA SSD S9FM01.8> at ata2-master PIO4 SATA 6Gb/s

Therefore I run:

echo "Prad4" > /var/etc/cfdevice

When I update I get:

Firmware upgrade in progress...
gunzip: error writing to output: Broken pipe
gunzip: /ftmp/firmware.img: uncompress failed
Image installed.
Done - rebooting system...

And can't boot from the SSD. Any ideas?
« Reply #7 on: September 06, 2014, 13:07:25 »
Jon Wall *
Posts: 3

Hi there,

I tried to install it from a cd-rom (1.8.1 iso image) on USB to SSD. device "ad4" is present in the boot log, but after choose the menu point, "install to harddrive" there show up a message "installing..." for 1 second and the main menu is back  Huh

wth is wrong with it. no error message. no informations from the software.

are there any linux commands to verify the ssd is writeable?!

thanks for your hints  Grin
« Reply #8 on: September 07, 2014, 16:56:22 »
yowsers *
Posts: 49

Jon wall, your problem sounds similar to this thread,5221.0.html  You can use "scroll lock" to scroll up and see the error.

You may have to use physdiskwrite to install, .  Your system may not be able to have both the usb cdrom drive and the ssd working at the same time and thus when you try to install from cdrom to the ssd as it is failing with "unable to mount cdrom" (most likely.)  You can try installing either an IDE cdrom or SATA cdrom and then install to the SSD to see if that fixes it but I am not sure.  Good luck.
« Reply #9 on: September 08, 2014, 00:37:51 »
Jon Wall *
Posts: 3

Jon wall, your problem sounds similar to this thread,5221.0.html  You can use "scroll lock" to scroll up and see the error.

Thanx for the Informations yowsers. Unfortunately I don't see any Error Message. When I boot pfSense and use there 99 to install it on harddrive it works without any problems to store the whole system to SSD (ad4)  Huh Roll Eyes

I tried it with physdiskwrite on Windows and dd on Mac OSX. Nothing worked. It's a bit frustating  Undecided It seems the project don't really supports the new APU and it's components and the installation documentation is outdated.
« Reply #10 on: September 10, 2014, 17:58:18 »
jstrebel *
Posts: 31

I run it on APU. just did a "dd"
« Reply #11 on: September 11, 2014, 11:03:56 »
brushedmoss ****
Posts: 446

sike: something wrong with your console, the devices is ad4, seems to have added some text before it in your console. so previous instruction in the thread should be good. 

you can confirm if you want by going to /exec.php and doing

ls /dev/ad*

and you should see /dev/ad4 as a device
« Reply #12 on: September 11, 2014, 11:06:26 »
brushedmoss ****
Posts: 446

John Wall:  can you try see the message , by pressing scroll-lock and then up arrow ?

otherwise the output of dmesg would help; go to /exec.php and type

cat /var/log/dmesg.boot

to see what your cdrom device is

Did you try instructions at start of thread ?  booting from USB stick of m0n0wall then doing an upgrade after modifying /var/etc/cfdevice

« Reply #13 on: December 04, 2014, 16:43:18 »
sike *
Posts: 2

I decided to give it another try. I can run_

echo "ad4" > /var/etc/cfdevice

I then update the Firmware:

Firmware upgrade in progress...
Image installed.
Done - rebooting system...

But then this happens when I reboot without the CF Card:

PC Engines APU BIOS build date: Apr  5 2014
Reading data from file [bootorder]
SeaBIOS (version ?-20140405_120742-frink)
SeaBIOS (version ?-20140405_120742-frink)
Found coreboot cbmem console @ df150400
Found mainboard PC Engines APU
Relocating init from 0x000e8e71 to 0xdf1065e0 (size 39259)
Found CBFS header at 0xfffffb90
found file "bootorder" in cbmem
CPU Mhz=1000
Found 27 PCI devices (max PCI bus is 05)
Copying PIR from 0xdf160400 to 0x000f27a0
Copying MPTABLE from 0xdf161400/df161410 to 0x000f25b0 with length 1ec
Copying ACPI RSDP from 0xdf162400 to 0x000f2590
Copying SMBIOS entry point from 0xdf16d800 to 0x000f2570
Using pmtimer, ioport 0x808
Scan for VGA option rom
EHCI init on dev 00:12.2 (regs=0xf7f08420)
Found 1 lpt ports
Found 2 serial ports
AHCI controller at 11.0, iobase f7f08000, irq 11
EHCI init on dev 00:13.2 (regs=0xf7f08520)
EHCI init on dev 00:16.2 (regs=0xf7f08620)
Searching bootorder for: /pci@i0cf8/*@11/drive@0/disk@0
AHCI/0: registering: "AHCI/0: SB mSATA SSD ATA-10 Hard-Disk (14318 MiBytes)"
Searching bootorder for: /rom@img/setup
Searching bootorder for: /rom@img/memtest
OHCI init on dev 00:12.0 (regs=0xf7f04000)
OHCI init on dev 00:13.0 (regs=0xf7f05000)
OHCI init on dev 00:14.5 (regs=0xf7f06000)
OHCI init on dev 00:16.0 (regs=0xf7f07000)
Searching bootorder for: /pci@i0cf8/usb@16,2/storage@1/*@0/*@0,0
Searching bootorder for: /pci@i0cf8/usb@16,2/usb-*@1
USB MSC vendor='Multiple' product='Card  Reader' rev='1.00' type=0 removable=1
scsi_is_ready returned -1
Unable to configure USB MSC drive.
Unable to configure USB MSC device.
All threads complete.
Scan for option roms
Running option rom at c000:0003

iPXE ( 00:00.0 C000 PCI2.10 PnP PMMpmm call arg1=1
pmm call arg1=0
+DF0E94B0pmm call arg1=1
pmm call arg1=0
+DF0494B0 C000

Searching bootorder for: /rom@genroms/pxeboot.rom

Build date: Apr  5 2014
System memory size: 4592 MB

Press F12 for boot menu.

Searching bootorder for: HALT
drive 0x000f2500: PCHS=16383/16/63 translation=lba LCHS=1024/255/63 s=29323728
Space available for UMB: c1000-ee800, f0000-f2500
Returned 253952 bytes of ZoneHigh
e820 map has 7 items:
  0: 0000000000000000 - 000000000009fc00 = 1 RAM
  1: 000000000009fc00 - 00000000000a0000 = 2 RESERVED
  2: 00000000000f0000 - 0000000000100000 = 2 RESERVED
  3: 0000000000100000 - 00000000df14e000 = 1 RAM
  4: 00000000df14e000 - 00000000e0000000 = 2 RESERVED
  5: 00000000f8000000 - 00000000f9000000 = 2 RESERVED
  6: 0000000100000000 - 000000011f000000 = 1 RAM
enter handle_19:
Booting from Hard Disk...
Boot failed: not a bootable disk

enter handle_18:
Booting from ROM...
Booting from c000:0363
iPXE (PCI 00:00.0) starting execution...ok
iPXE initialising devices...ok

iPXE 1.0.0+ -- Open Source Network Boot Firmware --

net0: 00:0d:b9:35:8d:2c using rtl8168 on PCI01:00.0 (open)
  [Link:down, TX:0 TXE:0 RX:0 RXE:0]
  [Link status: Down (]
Waiting for link-up on net0.... ok
Configuring (net0 00:0d:b9:35:8d:2c)...... ok
net0: gw
Nothing to boot: No such file or directory (
net1: 00:0d:b9:35:8d:2d using rtl8168 on PCI02:00.0 (open)
  [Link:down, TX:0 TXE:0 RX:0 RXE:0]
  [Link status: Down (]
Waiting for link-up on net1................. Down (
net2: 00:0d:b9:35:8d:2e using rtl8168 on PCI03:00.0 (open)
  [Link:down, TX:0 TXE:0 RX:0 RXE:0]
  [Link status: Down (]
Waiting for link-up on net2................. Down (
No more network devices

enter handle_18:
Booting from CBFS...
Run img/setup
No extension-based loader found
Calling addr 0x00100000

*** Sortbootorder payload    ver 1.1   Sage Electronic Engineering  *
Type lower case letter to move device to top
boot devices

  d mSATA
  a SD Card
  e SATA 2
  b USB 1
  c USB 2
  f SATA 3

Type upper case letter to invoke action
  R Restore boot order defaults
  N Network/PXE boot - Currently Enabled
  S Serial console - Currently Enabled
  E Exit setup with save
  X Exit setup without save


I can not get it to boot from the SSD.
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines