News: This forum is now permanently frozen.
Pages: [1]
Topic: [Gave up] Can't get m0n0wall to boot on APU1C4  (Read 1811 times)
« on: August 09, 2014, 18:19:48 »
hawkse *
Posts: 2


Long time m0n0wall user here. Old wrap board died from a lightning stroke the other week and now I've got my hands on an APU1C4 board.

Great - except it just won't boot!

Read this thread, and put the 1.8.1 generic image onto a fresh 8 GB SDHC-card. Got as far as the bootloader and then an error 'lba 1, no boot' over and over again.

Googled that, got some pfsense hits and freebsd. Figured it had to do with my rather large SD card so flashed another one, 1 GB, with the same image. That one gets to the stage where it shows the memory layout and then says 'booting from 0000:7c00' and just hangs.

Attached is the output from the entire startup sequence.
So now what? Any helpful hints?

Feel free to tell me to RTFM if it's all there - I couldn't find anything similar though :/

UPDATE: Got a bit further. Read this post at PCEngines about switching baudrate midboot since the APU uses 115200 and pfSense (like m0n0wall) uses 9600.

Once that was done, I could see the boot sequence of pfSense progressing but once again stopping due to problems reading from the SD card. Following the advice HERE on adding a boot parameter to pfSense did the final trick to get pfSense up and running.

Still no luck with m0n0wall 1.8.1 though Sad

* apu1c4nonboot.txt (2.16 KB - downloaded 60 times.)
« Last Edit: August 31, 2014, 11:06:32 by hawkse »
« Reply #1 on: August 12, 2014, 12:56:40 »
evongugg *
Posts: 31

Have you set the boot order in the bios to default to the SD card?

Page 6 of the manual.
« Last Edit: August 12, 2014, 13:04:55 by evongugg »
« Reply #2 on: August 12, 2014, 22:39:34 »
hawkse *
Posts: 2

Have you set the boot order in the bios to default to the SD card?

Page 6 of the manual.

Hi, yes, I've set the boot order to default to SD and it's booting pfSense fine from the SD card. It's just m0n0wall that doesn't seem to want to play ball. As I've detailed in my updated post, there were some steps to get pfSense to boot too. I find it weird though, since I see other people posting success running m0n0wall.
« Reply #3 on: September 11, 2014, 11:08:09 »
brushedmoss ****
Posts: 446

booting from the mSSD or usb key works fine, haven't tried ever from an SD card, which is where this problem is.  will have to see if I have an SD card somewhere
« Reply #4 on: September 16, 2014, 00:46:46 »
watercooled *
Posts: 11

Did the OP manage to resolve this?

I run m0n0 from an SD card on an APU1C myself and I'm trying to think back to when I first set it up but it was a while ago now and I did a bit of experimenting so can't exactly remember what was specific to m0n0.

If possible, post another log of where the boot stalls, while set to the correct serial speed.
Pages: [1]
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines